Sprint Gt Not Starting

Discussion in 'Forum News' started by John Tonks, Feb 8, 2020.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. John Tonks

    John Tonks New Member

    Feb 7, 2020
    2
    3
    uk
    new to this. I have a sprint Gt 2011. datatool s4 fitted by triumph.The red led light for the alarm has stopped working. the alarm seems to work.alarms and disalarms ok.Tried to programme another fob. Now the bike wont start.Bike not turning over,clutch pressed in,in neutral press start button not a sound.Battery is fully charged.Have checked fuses ok.Need help don't know if its a bike fault or an alarm fault.Have tried to get in touch with datatool but have not come back to me yet still waiting 2 weeks.Would welcome any advice or help on this. John Tonks.
     
    • Agree Agree x 1
  2. joe mc donald

    Subscriber

    Dec 26, 2014
    14,074
    1,000
    slough / burnham
    John Tonks
    Welcome to the family. Do hit the upload a file button bottom right corner and shoe the inmates the steed. Yes the alarm do seem to be more trouble than they are worth. Do get the lead to plug in and unplug the alarm to see if it works. Also make sure your battery is 100% percent. I had my 675 showing good battery but wouldn't start changed the battery and hey presto. Try a jump start. And look at your safety switches on the side stand and clutch lever.
    Regards
    Joe.
     
  3. John Tonks

    John Tonks New Member

    Feb 7, 2020
    2
    3
    uk
    Thanks Dozers Dad for the reply. Had the alarm changed under the recall.
     
    • Agree Agree x 1
    • Informative Informative x 1
  4. Sprinter

    Sprinter Kinigit

    Aug 17, 2014
    6,027
    1,000
    uk

    The LED may be a loose connection.
    How did you try to programme another fob?
    What time scale has this taken in?
    When you switch on are you getting noises whirring or what else?
    Do you have any lights instruments when you turn the key?
    Like a good detective they need every detail.


    https://www.thetriumphforum.com/thr...art-try-running-through-this-checklist.12935/
     
    • Agree Agree x 1
  5. John Tonks

    John Tonks New Member

    Feb 7, 2020
    2
    3
    uk
    Thanks Sprinter for your advice.Where does the led light go to.Havent been able to programme another fob as the led light is not working. Only managed to set pin number. Bike started one day next day nothing. When switching on you hear fuel pump priming. the instruments light up pressing starter switch no sound Will go through check list and see if that helps. Thanks John.
     
    • Like Like x 2
    • Agree Agree x 1
  6. BazSprintGT

    BazSprintGT New Member

    Dec 21, 2020
    10
    3
    Worthing, West Sussex
    Hi John,

    have you tried removing and stripping the clutch switch? Did mine and it now turns over faster than ever. Just a thought
     
    • Like Like x 1
    • Agree Agree x 1
Loading...

Share This Page