Welcome to The Triumph Forum

The World's busiest Triumph Forum. Join this amazing group of people and start discussing the thing that we all love, Triumph Motorcycles.

SPEED TRIPLE WARRANTY ISSUES

Discussion in 'Speed Triple' started by Col_C, Oct 11, 2016.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Tripster1050

    Tripster1050 New Member

    Jul 11, 2018
    21
    3
    Lancashire UK
    #81 Tripster1050, Jul 20, 2018
    Last edited: Jul 20, 2018
    Warranty claim or not ? new Speed Triple RS defect in tank paint. Dealer says “its part of welding process & happens. Its in the tank, not the paint so nothing to worry about, will look at 500 mile service” ??

    B01C1DFF-BA65-441F-9BAB-392CEF905023.jpeg
     
  2. Purpleronnie

    Purpleronnie New Member

    Dec 3, 2016
    11
    3
    Up North
    I'd be pushing for a new tank. It's going to draw your eye to it constantly. I've had 2 tanks replaced for far less visible faults. Both brought to my attention by the dealer.
     
    • Like Like x 1
    • Agree Agree x 1
  3. Tripster1050

    Tripster1050 New Member

    Jul 11, 2018
    21
    3
    Lancashire UK
    I am inclined to agree. Its actually under the plastic cover on the front of the tank so day to day wont see it but I know what you mean
     
  4. Red Thunder

    Red Thunder First Class Member
    Subscriber

    Dec 2, 2014
    1,269
    500
    High Wycombe
    Are you referring to that curly pube someone left behind from the paint shop!
    That's what it looks like on my phone anyhow
     
    • Like Like x 1
  5. Barryscott

    Barryscott Member

    Jul 7, 2018
    28
    18
    Tupelo, Ms, USA
    If it is under the cover, I wouldn't change out, but that's me
     
  6. Tripster1050

    Tripster1050 New Member

    Jul 11, 2018
    21
    3
    Lancashire UK
    exactly what it looks like to me too, :eek::)I said to dealer it looks like some foreign material though rather than a curly pube !!!!!
     
  7. Red Thunder

    Red Thunder First Class Member
    Subscriber

    Dec 2, 2014
    1,269
    500
    High Wycombe
    Under the cover or not, it is a defect in workmanship and covered by the warranty
    Should never have left the factory
    Maybe as a factory seconds for 1/3 the price B t certainly not suitable for a premium priced bike
     
  8. Tripster1050

    Tripster1050 New Member

    Jul 11, 2018
    21
    3
    Lancashire UK
    :(
     
  9. Red Thunder

    Red Thunder First Class Member
    Subscriber

    Dec 2, 2014
    1,269
    500
    High Wycombe
    Of course it is person choice and as I am very unconfrontational I would probably not raise a stink.

    I can't imagine it being too much hastle for the dealer to get a new tank in and spend 30min installing the pump and fuel cap from old to new
     
    • Like Like x 1
    • Agree Agree x 1
  10. Tripster1050

    Tripster1050 New Member

    Jul 11, 2018
    21
    3
    Lancashire UK
    I really like my dealer & appreciate mistakes are made in all work, I make mistakes in my job, but I love the bike and would prefer it be perfect rather than have a paint defect. Will see how it goes at the 500 mile service
     
    • Agree Agree x 1
  11. Cap City Murph

    Jul 14, 2018
    17
    8
    Carson city nv.
    Am having trouble with front break switch any one hhave a diagram
    On this?
     
  12. Arno triple

    Arno triple Well-Known Member

    Aug 26, 2018
    212
    93
    Netherlands
    Faulty gear indicator
    Hi all, I’ve got a 2018 speed triple rs, and drove it voor 1000 km now. After 800 km, got the maintenance notification as it should do. Then .... at 802 km: my gearindicator stops working. Stayed displayed in fifth, but was driving in second. 5 Kilometers further: TC error (no abs light, only tc) and within seconds: Motor management error. Called the dealer and he picked it up for a checkup. Did the 800 km maintenance, and reseted the ECU. No more problems... but today at 1020 km same problems occur. All is working, engine running fine, ABS working, TC light flashes on when opening throttle, so it seems to work ok. Only thing not working is gear indicator. Anyone any idea or perhaps had the same issues?
     
  13. Rspete

    Rspete Well-Known Member

    Jun 17, 2018
    371
    63
    Durham
    Mines going back on Saturday, to get the front brake discs renewed due to a horrid grinding sound.... also the quick shifter isn't working as it should when on full throttle it doesn't change gears from 4th to 6th but works fine on half throttle (weird).
    I'm not worried tho it will get sorted, triumph Newcastle have been great.

    It's also worth mentioning the fact I don't care about the problems.... I absolutely love Rosie rs. She's a part of my family now. :):p
     
    • Like Like x 3
  14. Arno triple

    Arno triple Well-Known Member

    Aug 26, 2018
    212
    93
    Netherlands
    Update:
    I’ve had contact with my dealer, he told me the following:

    gear indicator is faulty, causing the ecu to not be able to control TC,so TC gives an error. Because of this, the motor management light comes on as well.

    Sounds acceptable and logic to me. Also because all keeps working fine except gear indicator. When the gear indicator isreplaced, I will test it and keep you all posted.
     
    • Like Like x 2
  15. Arno triple

    Arno triple Well-Known Member

    Aug 26, 2018
    212
    93
    Netherlands
    Gearindicator Switch was faulty indeed. Some bloke at the factory put two O rings on it, dealer replaced the entire switch this morning, went for a test drive, all is working fine now
     
    • Like Like x 3
  16. Tripster1050

    Tripster1050 New Member

    Jul 11, 2018
    21
    3
    Lancashire UK
    Update on the tank paint defect...
    500 mile service Wednesday and checked the tank. Friday a new tank was at the dealers ready for replacing. Bike booked in next Tuesday.
    Who says Triumph are bad for warranty ?????? Great dealership service too
     
    • Like Like x 5
  17. Arno triple

    Arno triple Well-Known Member

    Aug 26, 2018
    212
    93
    Netherlands
    New one: cruise control not working. Also mapping change while riding doesn’t work. Informed the dealer, will pay them a visit next week. Keep you’ll posted!
     
  18. tcbandituk

    Subscriber

    Apr 8, 2016
    1,203
    500
    Reading
    Tell them to check the rear brake light switch.
    Also your brake light will probably be stuck on.

    I'm on my 3rd switch...
     
    • Like Like x 1
  19. Andymarksonline

    Andymarksonline Well-Known Member

    Aug 26, 2018
    126
    83
    Kent
    I'm having a new left had switch cluster fitted under warranty to my 2018 RS as the joystick is sticking, dealer was supposed to sort this before I picked it up as I noticed it on the test ride (I bought the demo) but didn't.

    Also front brakes make a grinding sound when wheeling it in and out the garage, not sure if this is normal. I have noticed a squeak coming from the brakes, ride along 30mph and dab the brakes slightly and it does it.
     
  20. Arno triple

    Arno triple Well-Known Member

    Aug 26, 2018
    212
    93
    Netherlands
    I’m driving in France right now, but spoke to my dealer already. Today pulled the rs into TC, and after lunch stop error disappeared. Will however inform my dealer about brake switch!
     
Loading...

Share This Page