Motodynamic Sequuential Led Tail Light

Discussion in 'Speed Triple' started by spony, Nov 14, 2019.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. spony

    spony Well-Known Member

    Oct 21, 2019
    124
    83
    scotland
    hi ,anyone fitted one of these to a 2019 ?
    instructions say an older style relay is required ,seems odd as they have led's as standard
     
    • Agree Agree x 1
  2. capt

    capt Noble Member

    May 8, 2016
    1,614
    450
    western Australia
    The warning might be for earlier model bikes which still have filament globes fitted ?
     
    • Agree Agree x 1
  3. Barryscott

    Barryscott Member

    Jul 7, 2018
    44
    18
    Tupelo, Ms, USA
    have one on mine, no problems
     
    • Like Like x 1
  4. SteveRS

    SteveRS Noble Member

    Jan 12, 2019
    502
    343
    British Columbia
    I have had the smoked version on my bike since new. So much better than the OEM. Here is a link to my mods build, it’s all in there. I hope this works.
    https://www.thetriumphforum.com/threads/mods-for-the-rs.17136/
     
    • Like Like x 1
  5. spony

    spony Well-Known Member

    Oct 21, 2019
    124
    83
    scotland
    thanks ,so no need for the sub harness with resistors? what about the earths ?
     
  6. spony

    spony Well-Known Member

    Oct 21, 2019
    124
    83
    scotland
    ok ,my new triumph front indicators are not working now ,i went to show them off to a friend but the rears were disconnected , now warning lights on the dash, can i reset it by disconnecting the battery ?or will that flag up more issues?
     
  7. topbanana0

    topbanana0 Well-Known Member

    Mar 27, 2016
    161
    93
    South Wales
    I fitted one of these to my mates 2014 speedy, didn't have any issues. Did need resistors if I remember correctly.
    Not sure what the problem with your indicators are?
    Are your front and rears connected?
     
  8. spony

    spony Well-Known Member

    Oct 21, 2019
    124
    83
    scotland
    I've ordered a dealer tool so will see what's up with the fronts as they were working fine before I took the back off .cant understand why you'd fit a non led flasher relay and resistors to a new bike with led as standard for the motodynamic but who knows ?
     
  9. Spspeed

    Spspeed Member
    Subscriber

    Jun 26, 2018
    80
    18
    Michigan
    On my '19 RS - no issues here. Been on there since new (July 2018) and working perfectly.
     
  10. spony

    spony Well-Known Member

    Oct 21, 2019
    124
    83
    scotland
    your will be non led though ,
     
  11. Spspeed

    Spspeed Member
    Subscriber

    Jun 26, 2018
    80
    18
    Michigan
    No, I have aftermarket AFC led indicators on the front and it works perfectly with the stock relay. No resistors. No hyper-flash.
     
    • Like Like x 2
  12. OhCrumOn

    OhCrumOn Well-Known Member

    May 2, 2019
    46
    68
    Phila
    Was plug & play on my 19' RS; had to route wires under the seat since space is limited out back.
     
Loading...

Share This Page