Vintage Tiger Tiger 955i 57plate With Low Miles - Fuel Gauge

Discussion in 'Tiger / Explorer' started by Hugh Murray, Jul 8, 2019.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Hugh Murray

    Hugh Murray New Member

    May 17, 2019
    9
    3
    Somerset
    Good evening folks, very happy owner of a very tidy tiger, has been well looked after and garaged and remarkably low miles, so Im giving it runs out to check things are ok before a trip in August. Just got back from a short run 25 miles from fuel tank and as I got near home the fuel gauge dropped and the light came on !? I switched it on and off a couple of times and the seems ok again - whats that about ???
    Also the plastic easy break fuel fittings - are these in the tank for the pump/filter or the fuel line connectors outside when removing the tank ?
    many thanks for any info
     
    • Agree Agree x 1
  2. thebiglad

    thebiglad Old fart, still riding !

    Sep 25, 2013
    5,011
    800
    Central France
    Hi Hugh re your questions :

    1. Fuel gauge strange readings - almost certainly the sender itself. Quite cheap to buy the part and easy to fit.

    2. The breakable plastic fittings on the underneath of the fuel tank and connect to the fuel pump. There are now metal replacements.
     
    • Agree Agree x 1
  3. Hugh Murray

    Hugh Murray New Member

    May 17, 2019
    9
    3
    Somerset
    Cheers for that !
     
    • Agree Agree x 1
  4. Hugh Murray

    Hugh Murray New Member

    May 17, 2019
    9
    3
    Somerset
    Have come back a week ago from a 2800 mile trip around Europe and 8 countries, went like a dream - lovely and smooth and plenty of power for me ! 9 tooth sprocket helps distance work, scottoiler kept things good at the back and the MRA Vario screen was soooo much better than standard. Now addressing the lumpy running with a O2 sensor blanker mod and re-doing connections for the fuel sender (the wires looked loose where they go into the base of the sender unit) also I have read that a common fault is poor earth from the wiring loom side of the connector so to add an extra earth there ?
    Love the bike and so lucky to find such a low mileage one - blimey its done all of 8900 miles now !
     
    • Like Like x 5
    • Agree Agree x 1
  5. Hugh Murray

    Hugh Murray New Member

    May 17, 2019
    9
    3
    Somerset
    #5 Hugh Murray, Oct 7, 2019
    Last edited: Oct 7, 2019
    Ok update - I have fixed the fuel sender which gave odd readings !
    I noticed the silicone seal where the wires come out the bottom was breaking up, so - tank off and drained, removed sender, took it apart and re-soldered the wires to the bottom of the pcb, checked resistance changed when sliding the floater up and down, resealed it with JB weld ultimate blackRTV silicone (petrol resistant), fitted a new rubber gasket and put back together - now working perfectly still after 3 tank fills.
    The O2 sensor blanker mod has defo smoothed things out big time at the lower revs and around town.
    Question - ive noticed when riding at night the headlights seem to sort of flicker a bit, is this the common alternator issue or just poorly fitted bulbs connections ? starts fine and lights go off when starting although the clock and odometer does fade.
    I want to fit a pair of LED low wattage driving lights, whats the best place to connect these in to, so they come on with the lights, or is the general wisdom to fit a separate supply & switch ?
     
    • Agree Agree x 1
  6. Hugh Murray

    Hugh Murray New Member

    May 17, 2019
    9
    3
    Somerset
    Update on this post - fuel sender has worked perfectly since the fix in Oct for interest of anyone with the same prob. LED running lights fitted and connected to side light wires with side lights now LED also - works fine. Also did the mod for headlights not coming on until start button released to make starting less load on battery - working great.
    Couple of odd things though - the LED's flicker while starting and when revving the engine the lights dim slightly !!? In my experience lights usually get slightly brighter when revving !
     
    • Agree Agree x 1
Loading...

Share This Page