Mytriumph App & 1200rs Speed Triple

Discussion in 'Technical Help' started by Fry, Sep 10, 2021.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Fry

    Fry New Member
    Subscriber

    Sep 10, 2021
    9
    3
    United Kingdom
    Hello all,
    I am new to the forum and to Triumph, just purchased a Speed Triple 1200RS.
    I am trying to set up the connectivity and have an issue I cant resolve. Note: I am using a 1st gen Apple iphone SE (2016)
    I have paired phone and headset to bike and it plays music and phone calls…so far so good.
    Downloaded MyTriumph app and followed instructions to “enable navigation” in the settings, ‘pairing instructions’ section. It will not connect and also it shows a cross on the connection status on the app despite the phone being paired as above.

    Please can anyone help out?
    Kind regards
    Fry
     
  2. Ducatitotriumph

    Ducatitotriumph Crème de la Crème
    Subscriber

    Apr 25, 2019
    1,776
    1,000
    Rothwell
  3. Neal H

    Neal H Member

    Mar 7, 2021
    69
    18
    England
    I’m another 1200RS owner, but I can’t offer much hard advise, sorry!

    I’ve also experienced connectivity issues where the nav seems to work then just immediately disappears with the app not paired message! I find I can normally get it working if I persevere by restarting the app. It’s a shame it’s such hard work as the bike nav works really well IF you can get it to work at all! Mine’s an Android phone so it isn’t just an iPhone issue.

    That aside, the bike is awesome
     
  4. Fry

    Fry New Member
    Subscriber

    Sep 10, 2021
    9
    3
    United Kingdom
    Thanks all for your help.
    I spoke with dealer yesterday who said this is a known issue with the RS and that an update was overdue for issue. They said it is due out imminently and will update on 1st service….fingers crossed!
     
    • Like Like x 2
  5. C Jay

    C Jay New Member

    Aug 12, 2021
    6
    3
    Dorset
    On my bike I had trouble too, I had to unpair my headset from my phone totally then i soley conect to the bike to the phone, then I turned on my headset and to repair it, it took quite awhile the first time to connect it all together.
     
    • Like Like x 1
Loading...

Share This Page