Little Coolant, White Sludge On Oil Filler Cap

Discussion in 'Speed Triple' started by Bmwjay1000rr, Jan 31, 2024.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Bmwjay1000rr

    Bmwjay1000rr Member

    Jun 23, 2021
    23
    8
    Cambridge uk
    Hi All
    Basically just bought a brand new speed triple 1200rs, my second one......only done 31 miles on the clock and noticed there's hardly no coolant in the reservoir tank and took the oil filler cap off to find white sludge on the cap and In the oil???? Any suggestions
    Many thanks
    Jason

    20240131_112635.jpg

    20240131_111525.jpg

    20240131_112556.jpg
     
  2. Bolosun

    Bolosun Well-Known Member

    Aug 25, 2020
    222
    93
    Crewe/Cheshire
    Take it to the dealers.
     
    • Agree Agree x 3
  3. Pegscraper

    Pegscraper Elite Member

    Jun 12, 2020
    3,051
    800
    Yorkshire
    With only 31m on the clock I find it hard to believe it wasn't spotted on the PDI.
     
  4. littleade

    littleade The only sane one here
    Subscriber

    Mar 17, 2015
    257
    1,000
    Worcestershire
    Just a guess but the mayonnaise is just condensation because the bike has been started but not run up to temperature and the dealer hasn't done the PDI correctly. As above take it back to the dealers and inform them that if it's not sorted you'll reject it under the consumer rights act 2015.
     
    • Agree Agree x 1
  5. Iceman

    Iceman Crème de la Crème

    Apr 19, 2020
    2,025
    1,000
    Lancashire
    Did you buy it from Triumph Essex, whatever dealer you did purchase it from take it back ASAP, as littleade says that machine has not been correctly PDI inspected. I would also be concerned about the dealer carrying out any future servicing as well.
     
Loading...

Share This Page