Sprint 2002 Sprint St 955i Chock Full Of Problems

Discussion in 'Sprint & Trophy' started by Fatguyonatriumph, Jun 10, 2023.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Fatguyonatriumph

    Fatguyonatriumph New Member

    Jun 10, 2023
    0
    1
    Pennsylvania
    Hello everyone. First time. Long time. I purchased a well worn 02 sprint st about two years ago. Bike ran fine up until last April. I mistakenly left it running at idle for about twenty minutes and it puked basically all of the coolant out. That day I putt putted it home, kept it from overheating, and parked it in the shed. Then it sat for a year. I tore the bike down, addressed the coolant issues ie checked all the hoses water pump etc. flushed it and called it a day. Since I purchased the bike, when it is at idle, I could hear what sounded like shots of air. I knew the idle control valve hoses needed to be replaced. So I went ahead and did that with some reinforced vacuum line. Yet I am still getting that same sound at idle. If not louder now. Checked all hoses. Everything still connected. Idle runs high, around 2100 rpm, until the bike runs for a bit and I goose the throttle a couple times. Then it seems to even out around 1400. I’m getting very delayed throttle response. I haven’t been able to find a thread on here addressing that same valve noise I am getting. Could it be a faulty stepper motor? I did the kill switch test and the plunger or whatever you want to call it goes up and down. So seems to be working. Possibly incorrect connecting points for the hoses? I haven’t been able to find a decent picture or diagram that resembles the throttle bodies my bike has.(nipples are on the backside of throttle bodies, facing rear of bike) And the way my brains set up I have a tendency to brain dump. So can’t be 100 percent sure I plumbed everything correctly. Coils and plugs looked fine. Fresh gas in it. Brand new battery (although if it sits for longer than a couple hours, it takes about seven or eight attempts to start it) All in all. I’m lost. The bike runs and rides. But it just sounds like spanked ass and throttle response is garbage and backfires like a pissed off fire cracker. Anyone have any ideas? I’m open to trying anything. I love the bike. And really don’t want to get rid of it.
     
Loading...

Share This Page