Turn Signals No Longer Work

Discussion in 'Technical Help' started by Gary Antonacci, Oct 9, 2023.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Gary Antonacci

    Gary Antonacci New Member

    Aug 12, 2023
    0
    1
    94708
    On my 2017 T100, the turn signals stopped working entirely. The dealer wants a ridiculous amount of $ to diagnose the problem. Any ideas on what I can do?
     
  2. Linx

    Linx Well-Known Member

    Mar 14, 2020
    197
    93
    Stratford Upon Avon, UK
    Anything else not working?
     
  3. Eldon

    Eldon Elite Member

    Nov 14, 2018
    4,159
    800
    North Yorkshire
    Have you checked the fuse?
    Probably under the seat or side panel.
     
  4. sprintdave

    sprintdave Nurse,he's out of bed again

    May 25, 2014
    1,495
    750
    Birmingham
    Fuse. Flasher Relay.Both easy fixes
     
  5. Gary Antonacci

    Gary Antonacci New Member

    Aug 12, 2023
    0
    1
    94708
    It's not the fuse. The problem was intermittent. The flashers would work fine, stop for a while, then work again. Now they don't work at all.
     
  6. MightyBoosh

    MightyBoosh Member

    Mar 29, 2023
    45
    18
    Uk
    This is your only other post on here:

    Aug 12, 2023
    I have a 2017 T100. After I disconnected and reconnected the battery both turn signals flash all the time and won't turn off. What to do?

    There looks like a bit of a connection here. Maybe if you update us as to what has been happening, and what resolution, if any, you came to from the original fault, it might be easier to help.
     
    • Like Like x 1
    • Funny Funny x 1
  7. Eldon

    Eldon Elite Member

    Nov 14, 2018
    4,159
    800
    North Yorkshire
    @MightyBoosh
    I get it, a bit of a connection :joy:

    Maybe if there was a full connection we wouldn't be having this discussion : unamused:
    Ok I'm on the wine and soon to bed :cool:
     
Loading...

Share This Page