Speed Rs Keyless Shenanigans

Discussion in 'Speed Triple' started by Alan Gilbert, Oct 24, 2021.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    I tested it again today and it’s still working fine but I absolutely agree - Given the contact strip is just wedged in place, it’s inviting the problem to recur at some point in the future.
    I don’t understand why it isn’t soldered down but would have to assume it could be due to the possibility of heat damage from the soldering process. I have a very fine soldering iron which I’ve used on PCBs so am confident I could do it but don’t want to toast the thing!!
    I’ll live with it for now.
     
    • Like Like x 4
    • Agree Agree x 1
  2. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    High peeps, I'm about to muddy the waters I'm afraid . . . . .
    It's been two weeks now and I've not been near the Speedy. She's been on an accumate whilst I serviced the Tiger and so it was - Curiosity Killed The Cat.
    After finishing the Tiger, I briefly nipped indoors yesterday, grabbed my Speedy Smart fob, switched it on and holding it in my hands only inches from the rider's seat, I pressed the starter button . . nowt, nada!! I've seen more action at a narcolepsy snoring convention.
    Initially, I wasn't even remotely concerned because I assumed the battery contacts were again compromised. I removed the backplate and with my thumb gently pressing against the battery, I tried again - bingo!! The bike powered up just great. Clearly, the contacts needed tweaking again. . . . . .
    I removed the battery and checked voltage.. . . . . . 3.08V - no problem here. I gave each contact a gentle bend and replaced the battery. My intention at this point was to insert a small piece of foam between the battery and the cover so that moving forward, the battery would be more proactively forced against the contacts. That said, prior to replacing the cover, I went back outside and tried the bike again - Speedy was once again in the land of nod. I applied pressure to the battery with my thumb - still nothing. No matter how much I tried - no joy.
    Once again, I removed the battery, cleaned it, checked all the contacts before replacing it and trying again - the bike remained like Rip Van Winkel on Prozac. It just didn't want to know, with or without pressure on the battery.
    I now held the key next to the shock but still switched on - the bike powered up no problem and thereafter, continued to do so when using the key in Smart mode and away from the shock. An hour later and my baby was snoring yet again and didn't want to know. I didn't test further because I was leaving home for the weekend.
    I really am baffled by this but have done a fair bit of reading and it would seem from all the problems reported by owners of bikes across the Triumph range, their keyless system is an unreliable piece of garbage.
    Next port of call will have to be the dealer but with the bike now sorned, it will either have to wait until the Spring or sooner if they can analyse the fob without seeing the bike. Feeling deflated . . . . . . . . .
     
    • Agree Agree x 3
  3. Ducatitotriumph

    Ducatitotriumph Crème de la Crème

    Apr 25, 2019
    2,126
    1,000
    Rothwell
    I (we) thought you'd cracked it :(
    Sounds like the ecu isn't "waking up" quickly? God knows. I'd like to say I feel your pain but I can't possibly.
    Ho hum, back to the head scratching :(:(:(:mad::mad:
     
    • Agree Agree x 1
  4. TRIPLE X

    TRIPLE X Active Member

    Sep 1, 2021
    55
    28
    Downham Market, Norfolk
    It seems that the not so smart key is indeed unreliable across all keyless models. It could well be an issue with the pcb within the key as well as poorly designed battery contacts?
     
    • Agree Agree x 1
  5. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    I'm beginning to wonder if it is a pairing issue.
    When removing the battery, the fob might undergo some form of hard reset and it could be something to do with this that allowed it to work previously when I cleaned the contacts etc and because it then worked, I quite reasonably assumed that it was cleaning the contacts that made the difference. That said, I have removed the battery twice in this latest incident and to no avail.
    It's always puzzled me that having powered up passively, the smart key seems to often work for a period of time aftwards and so maybe this passive start has some effect on the pairing of the key.
    I will investigate further when I get home but will be writing to Triumph technical with a long list of symptoms - not so much to aid my issue because I'm sure that now I'm out of warranty, they couldn't care less but hopefully, with some accurate symptoms, it might help them track down the issue and produce a system in future which works reliably.
    Clearly this case file remains open and so I will report back when and if there's anything new to say.
    I might even do a Boris and post the letter to Triumph so that folks know what is being said behind the scenes.
    One thing is for sure - I will never, ever buy another motorcycle with keyless ignition. It's a solution to a problem that doesn't exist but in solving the non-existent problem, the manufacturer is creating a massive new one which will cost them brand loyalty
     
    • Agree Agree x 4
  6. Col_C

    Col_C I can't re...Member

    Aug 5, 2015
    1,379
    800
    Cornwall
    As Triple X suggests it is now leaning towards a pcb problem, if there are "dry joints" (where solder hasn't flowed properly in manufacture) any slight flexing of the pcb will make or break the bad contacts, the only fix in that case will be a replacement fob.
    Alternatively the fact it works for a while after a passive start suggests there is a software issue and the ecu is not coming out of a sleep mode, but if so I would have thought Triumph would be aware of this by now and issue an update.
    I feel your pain, I had a Multistrada for a couple of years that had a number of software (and hardware) issues, but the keyless was one of the things that actually worked!
    I now have a 2015 Speed Triple (94R) with an old school key..... which is way more convenient because I always know where the key is when I need to stop to re-fuel. :laughing:
    (partial keyless is a ridiculous idea)
     
    • Agree Agree x 3
    • Like Like x 2
  7. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    I’ve had another thought. Lots of folks get range issues with their fobs and mine was working fine just two weeks ago and again, worked briefly just the once when I applied thumb pressure to the battery.
    The voltage on install was 3.24V but now down to just over 3V after two weeks but. . . . the key has been switched off. Perhaps the battery wilts further when under load?
    The battery in my car fob is a coin battery but much beefier than a 2032 plus I bought the “Energizer” 2032s off eBay. Given the voltage drop in just two weeks, it is possible the batteries are counterfeit and so I will try a Duracell from Tesco/High so I know the provenance.
    It could be that the 2032 needs to be of good quality and maybe, the spec itself is just too puny for the application.
    If it works, I might investigate battery dimensions to see if a battery with more depth will fit and perhaps have more a/h
    Can’t give up just yet. . . .
     
    • Funny Funny x 1
    • Agree Agree x 1
  8. TRIPLE X

    TRIPLE X Active Member

    Sep 1, 2021
    55
    28
    Downham Market, Norfolk
    I replace my key battery every 2 years regardless and always use Duracell as I believe them to be the best quality. Obviously only done it once so far on my 2019 RS.
     
    • Agree Agree x 1
  9. m4ppy

    m4ppy Well-Known Member

    Aug 7, 2013
    52
    68
    Not had the issue with mine yet, but the question over cheep batteries does affect my car keyless. I replaced with new Amazon/eBay batteries and had issues to the point I booked in for a fault. The dealer swapped out the fob with a known quality new battery, and I have had no issues for 6 months. The dealers did say it’s the number one issue they get with fake batteries or ones that have sat for years, rather than from a good source.
     
    • Like Like x 1
    • Useful Useful x 1
    • Agree Agree x 1
    • WTF WTF x 1
  10. Ducatitotriumph

    Ducatitotriumph Crème de la Crème

    Apr 25, 2019
    2,126
    1,000
    Rothwell
    I use duracell 2032 batteries (from asda) and i've not had an issue. I presume you know that 2032 means 20mm diameter and 3.2 v? No relevance but always nice to know!
     
    • Like Like x 1
    • Useful Useful x 1
    • Agree Agree x 1
  11. xorbe

    xorbe Senior Member

    Jan 27, 2021
    118
    143
    CA, USA
    3.2mm thickness ... not voltage ...
     
    • Informative Informative x 2
    • Agree Agree x 1
  12. Ducatitotriumph

    Ducatitotriumph Crème de la Crème

    Apr 25, 2019
    2,126
    1,000
    Rothwell
    I've been schooled!!! Thanks!
    I'll exit the building quickly and quietly!
     
    • Funny Funny x 1
    • Agree Agree x 1
  13. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    thanks . . .that's good to know (notwithstanding the 3.2might be thickness) I need to check the clearance above the battery and know how much room, if any, is available to accommodate a thicker battery. It might be an option.
    Meanwhile, I'm going home tomorrow night and will spend Wednesday running some experiments which should indicate whether or not the battery per se is the issue.
    Watch this space . . . .
     
    • Agree Agree x 1
  14. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    #74 Alan Gilbert, Nov 29, 2021
    Last edited: Nov 30, 2021
    OK - that idea was a non-starter. 2032 is the thickest of the 20 series and so I’m stuck with sourcing the best possible battery.
     
    • Agree Agree x 1
  15. Captain Trips

    Captain Trips Member

    Feb 4, 2019
    74
    18
    Surrey, UK
    I don’t have keyless so am not sure how much help this is, but when replacing a remote controller battery and not having a 2032 to hand, I have used 2 CR 2016’s sitting one on top of the other, they haven’t blown up the TV yet and are a tighter fit, but YMMV as they say (plus, it’s your bike not a cheap TV remote).
     
    • Agree Agree x 1
  16. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    thanks for the suggestion but I don’t think I’ll go there as overall thickness would still be 3.2mm but the voltage would be 6V instead of the 3V design spec - could likely be an issue.
    Will try a Duracell from a reputable source and see what happens. . .
     
    • Agree Agree x 1
  17. TRIPLE X

    TRIPLE X Active Member

    Sep 1, 2021
    55
    28
    Downham Market, Norfolk
    #77 TRIPLE X, Nov 30, 2021
    Last edited: Nov 30, 2021
    The voltage will still be 3V connected in parallel but the Ah will double? But I might be getting mixed up between 'in series' and 'in parallel' as the two batteries will connect in series therefore 6V as you say ?
     
    • Agree Agree x 1
  18. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    yes - stacking the batteries connects them in series and gives double volts.
    To connect in parallel you connect terminals with same polarity.
     
    • Agree Agree x 2
  19. Alan Gilbert

    Alan Gilbert Senior Member

    Nov 22, 2018
    282
    113
    Lincolnshire, UK
    #79 Alan Gilbert, Nov 30, 2021
    Last edited: Nov 30, 2021
    Good evening peeps . . . . I have some very encouraging news. . .

    I arrived home earlier this afternoon and tried out the RS. I switched on the key and pressed “start”. As expected, she was dead to the world - nothing. Bike battery showing 12.78V.
    I took the key indoors, removed the backplate and with finger firmly pressed down onto the battery, tried again - same result - the bike was snoring like a trooper!
    On the way home, I stopped off and bought a pack of Energizer cells - having read a number of reviews, I wanted Duracell because they came out best but hey ho . . . . beggars can’t be choosers and they didn’t have any.
    I removed the battery and replaced it with a new “Energizer” and then checked the voltage of the battery I had just taken out - 3.01V.
    This is crazy when you consider it has been in standby perhaps a total of ten minutes and has activated the fob LED maybe 4-5 times in total and yet, the battery has lost volts from its original 3.24v - a sure sign that something isn’t right.
    Before installing, the new battery was checked and found to be 3.31V and so, out to the garage I went again. I switched the bike on and off maybe 10 times and not one issue. Now. . . Bear in mind, I didn’t tweak the contacts or do anything more than simply switch out the battery.
    My current thoughts are that the batteries I had been using are fake and when under only a small load, will lose volts sufficiently so that the key fob simply fails to respond to the bike. On reflection, this supports some other observations I have made over the last 12 months - namely, I have put brand new CR2032s in my kitchen scales and my digital torque wrenches and both have shown the “half battery” symbol in a very short period of time but I simply hadn’t twigged. I just assumed they were battery-hungry devices or the indication was wrong.
    As an afterthought, I decided to measure the thickness of the old batteries but not wanting to short them with my digital calipers, I measured two at a time - negative to negative and with the calipers pressed onto each of the positive faces. The new batteries were 6.39-6.41mm and the old (“Panasonic”) batteries 6.27mm and so they weren’t even the right size - yet another pointer perhaps?
    OK - so there is another possibility - manufacturing tolerances could mean these things are not all 3.2mm +\- 0.001mm thick and could legitimately vary by the amount I found and the drop in voltage and loss of key function could be due to an internal short in the key which is thus causing the battery to drain over time. We will know in 2-3 weeks when I test the key again - meanwhile I have switched it off as before.
    My money is full square on the following and my personal prejudice dictates I have already made up my mind. . . .
    1. The battery contact arrangement is less than ideal and it wouldn’t hurt to at least ensure the contacts are adjusted adequately but this is not actually the problem. At least not in my case
    2. The main issue is caused by the supply of cheap, fake 2032s being sold through Amazon and on eBay - I’m now absolutely convinced and I would recommend only buying best brand batteries but more importantly from a major bricks and mortar retailer such as B&Q, Tesco or Boots etc. Buy your batteries from “Happy Bingo Batteries” on eBay and it seems you’re asking for trouble.
    These are the offending little turds!!!!

    D26E8EE7-D006-4574-80F4-4AD011B4E2F8.jpeg

    A6EB7D5B-3501-4563-9D02-C09DBA3EC838.jpeg
     
    • Like Like x 3
  20. xorbe

    xorbe Senior Member

    Jan 27, 2021
    118
    143
    CA, USA
    #80 xorbe, Nov 30, 2021
    Last edited: Nov 30, 2021
    Lithium batteries have a head charge that dips quickly from the peak voltage, then they hold a nominal voltage for a looong time, and then crater after that. So 3.01V is not unusual, as it is advertised as a 3V nominal battery. You kinda have to measure the voltage under nominal load, as an idle battery will often misleadingly recover to a good looking voltage (but have no juice to back it up). Dead is around 2.8V for a button battery, not much left after that.

    ERIwd.png
     
    • Agree Agree x 1
Loading...

Share This Page