Quickshifter Problem!

Discussion in 'Speed Triple' started by Andybow, Mar 1, 2019.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    Went for a decent ride today, on the way back the dash lit up with all sorts of codes.
    QS disabled, traction control disabled, no gear position was on display , there was just a line where the position is normally displayed. so it’s gone to the dealers for them to sort.
    Anyone had similar?
     
    • Useful Useful x 1
  2. Andymarksonline

    Andymarksonline Well-Known Member

    Aug 26, 2018
    238
    93
    Kent
    Not on a speed but my mate had a similar thing in his S1000R the dash went mental for a bit. Turned out to be a loose battery connection!
     
    • Useful Useful x 1
  3. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    Didn’t check that, but I think it may be a QS , Blipper sensor
     
    • Useful Useful x 1
  4. Sideburn

    Sideburn Well-Known Member

    Nov 27, 2018
    134
    93
    Colorado
    Could be, not saying you're wrong, but if you get lots of warnings it's likely canbus throwing bogus, random codes because the battery voltage is too low or you have a spotty connection. I've seen this before, stuck a volt meter on my battery and it read 9.8V. High enough not to die, low enough that the canbus shuts down or goes nuts. Replaced battery, all was fine.
     
    • Like Like x 2
    • Agree Agree x 1
  5. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    Cheers, I’ll see what the dealer says when I get it back, maybe it is the battery, it’s under warranty so they can deal with it, but I’ll be interested what they say
     
    • Agree Agree x 1
  6. James Fan

    James Fan New Member

    Apr 23, 2019
    1
    3
    Sydney, Australia
    Hi Andybow

    Has your QS issue been sorted out? I had the same issue with my Speedy RS - was riding at 80kph (50mph) in sixth when the same warning lights came on.

    The additional issue I have is that the bike doesn’t start with the kickstand down (even when the bike is in neutral - not that the dash shows what gear I’m in).

    The bike is only two months old so I’m going to take the bike back to the dealer first.

    James

    BBFC010B-4460-4A7E-9E62-E16E47DD3A74.jpeg
     
    • Like Like x 1
  7. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    Hi James
    3 x it’s been and each time they say it’s sorted, pain in the arse!
    It’s going in on Friday and I told them to replace quickshifter, whether they do is another thing!
    Where abouts are you ?
     
    • Agree Agree x 1
  8. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    Same as you re starting as well,
    Keeps throwing up quickshifter fault which I’ve now turned it off on the dash, but have engine mamangement light still on and sometimes traction control
    Disables itself
     
    • Agree Agree x 1
  9. Col_C

    Col_C I can't re...Member

    Aug 5, 2015
    1,442
    800
    Cornwall
    Are you holding clutch in when trying to start? If same as my 2015 still need to hold clutch in when starting in neutral ....... but will kill engine as soon as you select first if the side stand is still down - safe but embarrassing / annoying.
     
    • Agree Agree x 2
  10. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    It’s nothing to do with that, it’s the fact that the gear position indicator goes blank so the ecu doesn’t know if it’s in gear or neutral
     
    • Like Like x 1
    • Agree Agree x 1
  11. James Fan

    James Fan New Member

    Apr 23, 2019
    1
    3
    Sydney, Australia
    Took it back this morning and they spent an hour on it. Seems to be back to normal now. They said they played around with the gear position indicator without going into specifics. However, they also said that if it plays up again, they will need to fix or replace something.

    I had always thought it was an electronics problem, given that the bike felt fine mechanically.

    Here's hoping it doesn't come up again.

    I'm in Sydney, Australia. There's only a few Triumph dealerships here and its a pain in the backside for me to get to where I bought the bike - which is a 50 minute ride across town.
     
    • Agree Agree x 1
  12. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    Same for me re the dealers, it’s a hour away, I have a dealer 15 minutes away but I wouldn’t take any bike there , so I have to take it back to where I got it from. Let me know if it comes back I’d be interested as to if it’s resolved the issue
     
    • Agree Agree x 1
  13. SteveRS

    SteveRS First Class Member

    Jan 12, 2019
    862
    500
    British Columbia
    Today when I was riding under hard acceleration the quick shifter didn’t want to change up into 5th during one run. And on another run it hit neutral, briefly, on the way to 5th. It reved very high then slammed into 5th. Maybe I didn’t pull up on the shifter positively enough because it never happened again.
     
    • Agree Agree x 1
  14. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    This is what mine did 2-3 times then I got the warning light, it’s been in and out of the dealers now, still no fix
     
    • Agree Agree x 1
  15. SteveRS

    SteveRS First Class Member

    Jan 12, 2019
    862
    500
    British Columbia
    Thats totally shitty man. Maybe mine will start doing the same, hope not.
     
    • Agree Agree x 1
  16. Eldon

    Eldon Elite Member

    Nov 14, 2018
    4,676
    800
    North Yorkshire
    #16 Eldon, Apr 25, 2019
    Last edited: Apr 25, 2019
    Seems weird all these QS issues on the Speed. I have the 765 with QS and the box is really sweet. Full on never a problem but I have had a few rev ups due to my cock ups. This only happens when going steady or focused on traffic. If i linger on the gear lever the system doesnt like it and it all goes a bit out of sync.
    On yours I wonder if the gear lever or selector drum is sticking/pausing for some reason especially if the 5th gear milled path in the selector drum is a tortuous one.

    Just an idea,
    What would happen if you unplugged the QS and rode it old style?
    Surely this would prove mechanically that the box and clutch were right wouldn't it?
    Then it's just a switch or electronic issue.

    On my Honda, lazy shifts into 4th or 5th (can't remember) sometimes gave neutral and I put it down to the drum having to do a lot of work with multiple forks on that shift with insufficient force provided by the rider. Full on shifts the box was sweet so nothing wrong as such but a foible of the design.
    Try different lever forces and see if it makes any difference.
     
    • Agree Agree x 1
  17. tcbandituk

    Subscriber

    Apr 8, 2016
    2,804
    1,000
    Reading
    Or a wetware issue.
    It takes a while to get used to used to a quickshifter, without automatically using the clutch or backing off the throttle, which can cause hiccups/ issues.
    Even if you think you're not doing it, muscle memory still can take over.

    I had this issue when getting used to an airshifter on my race bike.
    I would swear blind I wasn't touching either clutch or throttle, but the data logger proved me to be a liar :mad::D
    It took a while to stop it altogether....
     
    • Agree Agree x 2
  18. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    If I turn off the quickshifter function on the dash I can normally shift with a clutch the qs warning light goes off but still has a engine management light on and sometimes the traction control just turns off for no reason. I’ve had a few bikes with quickshifters and never had a problem. My brothers Tuono is probably the best qs blipper I’ve ever tried
     
    • Agree Agree x 1
  19. Andybow

    Andybow Well-Known Member

    Jan 31, 2018
    160
    93
    Uk Exeter
    I’m nearly 3000 miles in now, never had a problem up until 2000 miles
     
    • Agree Agree x 1
  20. Eldon

    Eldon Elite Member

    Nov 14, 2018
    4,676
    800
    North Yorkshire
    I'm wondering if your problem Andy isn't about gear shifting per se but you have some background electronic or software issues.
     
    • Agree Agree x 1
Loading...

Share This Page